BigPicture Power-Up Maintenance
Incident Report for SoftwarePlant
Resolved
This incident has been resolved.
Posted Jan 10, 2020 - 09:35 CET
Investigating
We'll be down for an maintenance our BigPicture power-up for Trello. A BigSorry for any inconvenience!
Posted Jan 10, 2020 - 09:07 CET
This incident affected: BigPicture (BigPicture Trello Power-Up).