BigPicture Trello Power-Up is unavailable
Incident Report for SoftwarePlant
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 09:39 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 06, 2021 - 09:04 CEST
This incident affected: BigPicture (BigPicture Trello Power-Up).