BigPicture Jira Cloud availability problems
Incident Report for SoftwarePlant
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 22, 2019 - 18:09 CET
Investigating
We are currently investigating this issue.
Posted 3 months ago. Mar 22, 2019 - 15:47 CET
This incident affected: BigPicture (BigPicture Jira Cloud App).